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BERXHE

xR TESH

RSIETT

TELTFRS

BUI{E gitee TEHS, Hillt: https://gitee.com/risesoft-y9/y9-core.git,

EiRlRE

=

FRrEERIB IR utf-8,

SRR FIREREPEGECIRIRERETRE, HEZTEF/ y9_public RIEHEE
(mEEHE0F utf8mb4)

SRR FIREREPEGECIRIRERETRE, HEZTEF/ y9_public RIEHEE
(IS8 F utf8mb4)

SRR FIREREPEGECIRIRERETRE, HEZTEF/ y9_public RIEIEE
(mEEHEF utf8mb4)

IDEA

SINIRHE

FJFF IDEA, i%8E open , HEFEBERERRINEFEER y9-core (& common, starter,
support &) ¥JFF
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[ ] . y9-core v 2 main v

3 Project v

o 3 y9-core [y9-digitalbase]
> D
> Dstyle
> Dvue
> [ y9-digitalbase-common
> [3y9-digitalbase-example
> [ y9-digitalbase-idcode
> [3y9-digitalbase-starter
> [ y9-digitalbase-support
> [3y9-digitalbase-webapp
= .gitattributes
@ .gitignore
CHANGELOG.md
= HEADER
= LICENSE
pom.xml
README.md

> [ External Libraries

IFBIETT | BRI

¢ DemoKernelApiApplication v > O

Search Everywhere
Go to File

Recent Files
Navigation Bar

Drop files here to open them

> = Scratches and Consoles

%

y9-core > README.md B 868 of 4300M

(ECRECE S

B ZIRSBHIBCESH application.yml , & MySQL. Redis, Kafka FEIRSimAFIZREHIT
BRSNS, (MR ERERERHFRENESAZEDIRENS N FEEERD, WAE
BXEE . )

XFARAERSIE, MNANRERLAARIEN

yami
spring:

datasource:
druid:
y9-public:
url: jdbc:mysql://localhost:3306/y9 public?serverTimezone=GMT%2B8&nu
username: root

password: 111111

BCEHNERFRTERY IP B, TRrheBsRENZiRit=R IP, SRR FZ M-SR

yami
y9:
internallIp: 192.168.x.X,10.0.X.X,172.20.X.X
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mFIRE

#FIREEPERT Aspectj YJHE,

IEFREAN

IRIGIETT | BERY

ZfEF IDEA izTIERT,

10ei% N EIRRT A —HRRIE] :

4 AspectdJ i, 188 Ajc miFss

S SA, BT IDEA STSIEEME, §

EIRMIRIFTA T

FJFF settings - Plugins , {H@EMHFMIZPHKEIRGRE

Q-

v Appearance & Behavior
Appearance
New Ul
Menus and Toolbars
System Settings
File Colors
Scopes
Notifications
Data Editor and Viewer
Quick Lists
Path Variables
Presentation Assistant
Keymap
> Editor
Plugins
> Version Control
v Build, Execution, Deployment
> Build Tools
v Compiler
Excludes
Java Compiler
Annotation Processors
Validation
RMI Compiler

EFE ajc fmiFEs

Settings

Installed 3

Plugins Marketplace

5 e AspectJ

Search Results (2) Plugin homepage 7

AspectJ

Disable v 241.17011.2

Overview What's New Reviews Additional Info

AOP Pointcut Language
Adds support for AOP with AspectJ.

* Create aspects either as . aj files or .java files
containing classes annotated with @Aspect

» Use code completion and refactorings for aspects

* Run the AspectJ compiler ajc from the IDE

» Configure ajc at the project level and fine-tune it at the
level of individual modules

To enable the AspectJ plugin, add a library containing
aspectjrt.jar to your project, and then add an AspectJ
facet with corresponding dependencies, if they are required
for developing your aspects.

Cancel
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Appearance & Behavior

Appearance

New Ul

Menus and Toolbars
System Settings
File Colors

Scopes
Notifications

Data Editor and Viewer

IFBIETT | BRI

Settings

Build, Execution, Deployment > Compiler > Java Compiler

Use compiler: | Ajc

»~| Use '--release’' option for cross-compilation (Java 9 and later)

Project bytecode version:

Per-module bytecode version:

+

Module Target bytecode version

3 risenet-y9boot-3rd-jpa

1.8

Quick Lists
Path Variables

Presentation Assistant

[ PN, NS~ S, .|

Keymap
) Ajc Options
> Editor
Plugins Path to aspectjtools.jar:

> Version Control

. . Command line parameters:
v Build, Execution, Deployment

> Build Tools + Generate debug info

~ Compiler v Delegate to Javac

Excludes

3 risenet-y9boot-api-feignclient-log

3 risenet-y9boot-api-feignclient-platform
(3 risenet-y9boot-api-interface-log

1.8
1.8
1.8

Bvec e e an

tory/org/aspectjjaspectjtools/1.9.20.1/aspectjtools-1.9.20.1.jar

-showWeaveInfo

Enable annotation processing options

Java Compiler
Annotation Processors
Validation

RMI Compiler

Cancel

File = Project Structure - Facets HRA)GEFHZE] Aspectd RRPIFIFFEANYTIENS 1%

iE:

ERER:
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Project Structure

&« + — Compiler

Project Settings AspectJ v Post-compile weave mode

Project AspectJ (risenet-y9boot-support-file-jpa-repository) Aspect path:
Modules AspectJ (risenet-y9boot-support-platform-service) A —
Libraries Web . .
th Maven: org.springframework:spring-aspects:5.3.31
Facets @ Web (risenet-y9boot-common-nacos)
Artifacts @ Web (risenet-y9boot-starter-web)

Platform Settings @ Web (risenet-y9boot-support-log-web)
SDKs

Global Libraries

@ Web (risenet-y9boot-support-platform-service)
@ Web (risenet-y9boot-support-platform-web)
Problems @ Web (risenet-y9boot-webapp-filemanager)

@ Web (risenet-y9boot-webapp-log)

@ Web (risenet-y9boot-webapp-platform)

@ Web (risenet-y9boot-webapp-sso-server)

@ Web (risenet-y9boot-webapp-sso-server-jpa)
@ Web (risenet-y9demo-file)

@ Web (risenet-y9demo-idcode)

@ Web (risenet-y9demo-kernel-api)

@ Web (risenet-y9demo-sso-oauth2)

® Web (risenet-y9demo-sync-kafka)

Detection

Facet 'AspectJ' is imported from Maven. Any changes made
in its configuration might be lost after reimporting.

Cancel Apply

1% IDE 133 £/i51T1R{EZIELE Maven
A ESFNEMBEAE, BSNERETIEESHHITIRTER Maven 1352, LEEHER

FA17E maven B9 pom.xml 5| N7 aspectj-maven-plugin X Ma&EH, EICEERIES
Maven f5 aspectj-maven-plugin fRESIBYIER
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Q-
Appearance & Behavior
> System Settings
File Colors
Scopes
Notifications
Data Editor and Viewer
Quick Lists
Path Variables
Presentation Assistant
Keymap
> Editor
Plugins
> Version Control
v Build, Execution, Deployment
v Build Tools
v Maven
Importing
Ignored Files
Runner
Running Tests
Repositories
Archetype Catalogs
Gradle
Gant
BSP

S — —

=17

A EFRSNERRY serviet FestBAI(ERAAERAY serviet R THEE, LALLA Tomcat J9ffl

9MEB Tomcat

IFBIETT | BRI

Settings
Build, Execution, Deployment > Build Tools > Maven > Runner

+ | Delegate IDE build/run actions to Maven

VM Options:

Options specified in this field override the ones in .mvn/jvm.config files

JRE: [3 Use Project JDK

Environment variables:

Properties:

Skip Tests
e

BRI IRSH E T UESIXIMNARSS &

TiERF IRSS &R
risenet-y9boot-webapp-sso-server SSO
risenet-y9boot-webapp-platform platform
risenet-y9boot-webapp-log log

https://docs.youshengyun.com/digitalbase/backend/sourcecode-deploy
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D] Run/Debug Configurations

TP K 12

Add New Configuration =

¥ Local

Name: all

Server Deployment Logs Code Coverage  Startup/Connection
Application server: Tomcat 9.0.54

Open browser

After launch Default with JavaScript debugger

URL: | http://localhost:7055/ss0

VM options: -Dfile.encading=UTF-8
On 'Update' action: Restart server Show dialog

On frame deactivation: | Do nothing

JRE:

Tomcat Server Settings

HTTP port: 7055 Deploy applications g
HTTPs port: Preserve sessions ac
IMX port: 1099

AJP port:

Ak Tomcat

N T ERSFRETHIT war  (BMERRRER serviet §28) & EFRAYINE serviet FeEfE, AR
B EAIKENZRE AT provided FRLAERBNERAY serviet ST IGEKELRIIZE] classpath
b, BEJeESEohiRiEER D&
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+ -0 8 &
v [ Application
Y9demoFileApplication
[“JPlatformApplication
Y9DemoLogApplication

IRIGIETT | BERY

Run/Debug Configurations

Name: PlatformApplication (] store as project file

Runon: (A Local machine v | Manage targets...
Run configurations may be executed locally or on a target: for

example in a Docker Container or on a remote host using SSH.

CodeApplication
LogApplication
> ) Spring Boot

Build and run

java 11 SDK of
> 7% Tomcat Server

-cp risenet-y9boot-webapp-platform

net.risesoft.PlatformApplication

Program arguments

Press X for field hints

Working directory:

Environment variables:

Separate variables with senf

Open run/debug tool window when started

Add dependencies with “provided” scope to clas

Code Coverage

Packages and classes to include in coverage da

+

4

net.risesoft.*
Edit configuration templates...

REZ IGRIR R MRS, EftbirsSit

R SRS

pEI=E I

RAOIET: MySQL :

Variable_name Value
character set_client utf8mbd
character set connection utf8mb4
character set database utfBmb4d
character_set_filesystem  binary

F character set results utf8mbd
character set_server utf8mbd
character set system utfd

bz filesystem, ¥
&R set character_set_client = utf8 (ANHETF,
A File>Settings

https://docs.youshengyun.com/digitalbase/backend/sourcecode-deploy

'risenet-y9boot-webapp-platform'

Environment variabl

NEFIGERIIHW IR, FEEE .

Modify options v | TM

Add Run Options

module

Operating System

JUsers/tobin/WorkSpace

Allow multiple instances AU
v Environment variables ~XE
Redirect input
Java
Do not build before run
v Use classpath of module A0

Modify classpath

v/ Add dependencies with “provided” scope to classpath

Implicitly declared class run configuration
Shorten command line
Add VM options AV
Logs

Specify logs to be shown in the console

Save console output to file

Show console when a message is printed to stdout

Show console when a message is printed to stderr

Code Coverage
Vv Specify classes and packages
Exclude classes and packages

P afmen § e n

TRFREREIRIA
SERERNRO, BNA—ERESHRNEEFEREN

show variables like "%char%"

Hitss/mutt8, EEERE (FHfL) ﬁB PEFERESR. WRILIEEIERE

ETE’J) —.r—.r, ;EIXEO IDEA: KLk
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Editor : File Encodings

Encoding:

Encoding
UTF-8
UTF-8

UTF-8

File Encadings

Transparent native-to-a

Eclipse

SINIRE

1. ;‘i% File - Import , QK}EJ‘?_’E}% Maven —> Existing Maven Projects , ,lf—\'_'\.—__E Next > ¥&%
H, BETIEER, RE/RE Finish %8, BIAIAINISAN.  Eclipse SEDMNEL Maven (K5
8, YIXINEtRE (IRIEESMEERME)
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- 49 Import Maven Projects O *
Maven Projects
Select Maven projects
Root Directory: | Ch\Users\ginma\Deskitoply9-core-master\y3-core-master vH Browse...
Projects:
v @ /pomxml netrisesofty9-corend.8.2-SMAPSHOT:pom Select All
B common/risenet-y3boot-properties/pomam| netrisesoftirisenst-y9boot-propertiesd.i
Deselect All

B common/risenet-y3boot-common-model/pomxml| netrisesoftrisenst-ySboot-common
B common/risenet-y3boot-common-nacos/pomaml netrisesoftirisenst-y8boot-common-
B common/risenet-y3boot-common-util/pomxml netrisesoftirisenst-yIboot-common-uti

B commonfrisenet-y3boot-common-tenantDataSource/pomaml net.risesoftrisenst-y9hao

B common/risenet-ydboot-3rd-jpa/pomxml netrisesoftrisenst-yBboot-3rd-jpand.6.2-5M
B e=xamplefrisenet-y9demo-kernel-apifbackend-demo/pom.axml| com.examplerizsenst-y9d
B =xample/risenet-y9demo-sso-cauth2/backend-demo/pomaml com.exampleirisenst-y2

B examplefrisenet-y9demo-sync-kafka/pomaxml netrisesoftirisenst-yOdemo-sync-kaflkan

Select Tree

Deselect Tree

Refresh

@ rest/risenet-y9boot-rest-interface-platform/pomaml net.risesoftirisenst-yOboot-rest-interface-platform:av8.6.2

@ restfrisenet-yIboot-rest-feignClient-platform/pom.axml netrisesoftrisenst-yYboot-rest-1
@ starter/risenet-y3boot-starter-apisi/pomaml| netrisesoftrisenet-ySboot-starter-apisix
B starter/risenet-y9boot-starter-cache-redis/pomaxml| net.risesoftirisenst-yOboot-starter-c

@ starter/risenet-y3boot-starter-dbComment/pom.axml netrisesoftirisenst-y9boot-starter-

B Add project(s) to working set

y9-core

» Advanced

® = Back Mext = Finish

Cancel

(ECRECES I

IEMZIRSHIECE S application.yml , & MySQL, Redis. Kafka ZiRSSimOFIZRIXN

B CRIIRSHIANZS. (MR EREFRENBAERRERNS N HEEERS, UAE

IEMECES . )

S—

=17

A Bd&Servers, [ FRIROIBEFERA7055, jdkER1,

BUiRIRE
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IZ1TRUIR
node.js hiZs v14.20.0 & ESIRA
XAIEENEEX A ENMXEFRBINEIRE, SELENEREFR, Bieimit
IBIETHER, A BB T RERIREBER.

s

$JFF cmd

$ cd vue\y9vue-kernel-standard # kN TR 135
$ npm i # “ZEEK
$ npm run serve # KHILHETERE, BT

Aiim LFEERAER 7070 imA.
WNRFEEPEBZNEAMIAE, ATLHIT npm run build 8¢& npm run build-test 3 TEEZEZEI1E
R MIRIAEE, TZEIEM .env.production B .env.test PRIELES

nlabESS

=1TRINfS, V5I8)BUURIAME http://localhost:7070/kernel-standard/

NS

RAEER BERB: systemManager Zf3: Risesoft@2022
LZo(RFR BREF: securityManager Zf5: Risesoft@2022
ZEEITR BER%L: auditManager Zf3: Risesoft@2022

EHAYE: 20241088 H 28— 11:25:27

£ T
war JUEE T DM (&%)
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